Sparqee Modem Hang

The SparqEE CELLv1.0 device.
nando2016
Posts: 7
Joined: Wed Jun 29, 2016 7:35 pm

Sparqee Modem Hang

Postby nando2016 » Thu Apr 13, 2017 2:03 am

Hi,

I am having a sparqee cell with shield running raspberry pi 3+.

After sending sms by pdu for a while, the modem hangs. When I minicom in, no AT command can be accepted.
Even after running the turn on script does not help.
We have to manually switch off the power and on back so that the modem can be alive again.

We try to toggle the power but to no avail. During hang state, it seem it does not response to any gpio pins.

Can you advise is there a inherent bugs in the ZTE modem or is there any firmware to update?

User avatar
donjohnii
Site Admin
Posts: 686
Joined: Tue Jul 30, 2013 2:19 pm

Re: Sparqee Modem Hang

Postby donjohnii » Thu Apr 13, 2017 3:57 am

Only a HW reset helps?

Have you implemented a protocol such as suggested in:

viewtopic.php?f=3&t=1544

User avatar
donjohnii
Site Admin
Posts: 686
Joined: Tue Jul 30, 2013 2:19 pm

Re: Sparqee Modem Hang

Postby donjohnii » Thu Apr 13, 2017 3:58 am

Have you done the turn off script to power it down rather than just a reset?

nando2016
Posts: 7
Joined: Wed Jun 29, 2016 7:35 pm

Re: Sparqee Modem Hang

Postby nando2016 » Thu Apr 13, 2017 8:11 am

Hi,

I cannot even do a AT during minicom. It would just refuse any input and naturally there will not be any return result.

I have tried power down but it does not response at all.

I tried your script and I notice the following:

The first module wakeup is 0 compared to module wakeup is 1 during normal operation.
How do I get maw to wake up?

User avatar
donjohnii
Site Admin
Posts: 686
Joined: Tue Jul 30, 2013 2:19 pm

Re: Sparqee Modem Hang

Postby donjohnii » Thu Apr 13, 2017 9:54 am

The power down needs to happen if the modem hangs (for whatever reason and is unwilling or unable to come back). Holding PO low for several seconds will shutdown the module and then toggling it more quickly will turn it back on.

The functions in the library should be defined with wait times which will cause a shutdown and startup so you shouldn't need to code anything there.

If the modem wont respond, I would operate under the assumption it crashed and isn't coming back. The 'check' procedure could be done periodically or prior to each use.

nando2016
Posts: 7
Joined: Wed Jun 29, 2016 7:35 pm

Re: Sparqee Modem Hang

Postby nando2016 » Tue Apr 18, 2017 3:55 am

We have called the gpio_turnOff() which will hold the PO low for 6 seconds and then gpio_toggle().

The blue light remains and modem remains hang.

What is the actual sequence of codes that need to power down the modem? (PS we are trying to shut down the modem to make sure this work first.)

In our findings, the modem will hang after a while even with no activity.

User avatar
donjohnii
Site Admin
Posts: 686
Joined: Tue Jul 30, 2013 2:19 pm

Re: Sparqee Modem Hang

Postby donjohnii » Wed Apr 19, 2017 2:10 am

nando2016 wrote:We have called the gpio_turnOff() which will hold the PO low for 6 seconds and then gpio_toggle().

The blue light remains and modem remains hang.

What is the actual sequence of codes that need to power down the modem? (PS we are trying to shut down the modem to make sure this work first.)

In our findings, the modem will hang after a while even with no activity.


It pulls PO low for 6 seconds. It may be possible there is a sync issue... I'd suggest trying to gnd PO and see if that turns off the module.

If it is truely falling to sleep, try the gpio_turnOn function to bring it back up - which is just an instantaneous GND to PO. I'll see if there is another status pin for brininging it out of sleep... but I don't believe so.

User avatar
donjohnii
Site Admin
Posts: 686
Joined: Tue Jul 30, 2013 2:19 pm

Re: Sparqee Modem Hang

Postby donjohnii » Wed Apr 19, 2017 9:51 am

There are a couple of things to try to debug based on the 5 status I/O lines. If you look at the datasheet, the 5 lines are for:

2 Main Lines
PRN - reset's the board
PO - controls on/off functionality

5 Status lines:
AR (input) - Module (CELLv1.0) checks if AP is asleep
MR (output) - Module sleep status... If it's asleep, this will be lit
AWM (input) -
MWA (output)- Module (CELLv1.0) wakes up AP (Client)
MP (output) - Module Poweron indication

I don't use these status lines much, but it's possible I have them connected in a certain way in my tests that I cause it to stay on. So I would suggest that you provide:
-AR 0V to tell the module that the the client is available
-AWM 0V to tell the module to wakeup if it is sleeping

Then check the status lights of:
-MR to make sure it's dark (LED off) indicating it's awake
-MWA should be lit (LED on) to indicate that the module is telling the AP to be awake
-MP should always be lit (LED on) indicating power to the module

nando2016
Posts: 7
Joined: Wed Jun 29, 2016 7:35 pm

Re: Sparqee Modem Hang

Postby nando2016 » Thu May 18, 2017 7:04 pm

Hi,

We have this pattern. We are sending normal SMS for quite number of times successfully. Then the modem will fail sending.
So if we keep on sending AT command, the modem will hang indefinitely where all software reset is not even possible.

Is this a firmware issue? Can we update the firmware of ZTE?


Return to “CELLv1.0”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests